This issue should now be resolved and all services are restored to normal functionality.
Please don’t hesitate to reach out to support@plugchoice.com if you have any further questions or if you’re still seeing any unexpected behaviour
Resolved
This issue should now be resolved and all services are restored to normal functionality.
Please don’t hesitate to reach out to support@plugchoice.com if you have any further questions or if you’re still seeing any unexpected behaviour
Identified
We are currently experiencing issues with email delivery due to an upstream fault at our email provider. As a result, users may be unable to complete registration, receive password reset emails, or get invitation emails.
Our team is actively monitoring the situation and working with the provider to resolve it as quickly as possible. We will provide updates as more information becomes available.