This issue should now be resolved and all services are restored to normal functionality.
Please don’t hesitate to reach out to support@plugchoice.com if you have any further questions or if you’re still seeing any unexpected behaviour
Resolved
This issue should now be resolved and all services are restored to normal functionality.
Please don’t hesitate to reach out to support@plugchoice.com if you have any further questions or if you’re still seeing any unexpected behaviour
Identified
We're seeing issues with statistics where some dashboards may be unavailable. Chargers are not affected. Our team is aware and has identified the issue. We'll update you here as soon as we have more information.